Как поставить сумму в excel автоматически
Перейти к содержимому

Как поставить сумму в excel автоматически

  • автор:

Использование функции СУММ для суммирования чисел в диапазоне

Для суммы чисел в диапазоне (группе ячеек) можно использовать простую формулу, но функцию СУММ проще использовать при работе с несколькими числами. Например, =СУММ(A2:A6) реже имеет ошибки при вводе, чем =A2+A3+A4+A5+A6.

Использование функции СУММ для двух диапазонов чисел

Вот формула, использующая два диапазонаячеев: =СУММ(A2:A4;C2:C3) суммирует числа в диапазонах A2:A4 и C2:C3. Чтобы получить итоговую сумму в 39787, нажмите ввод.

Чтобы создать формулу:

  1. Введите в ячейку =СУММ и открываю скобки (.
  2. Чтобы ввести первый диапазон формул, который называется аргументом (частью данных, которую нужно выполнить), введите A2:A4 (или выберите ячейку A2 и перетащите ее через ячейку A6).
  3. Введите запятую (,), чтобы отделить первый аргумент от следующего.
  4. Введите второй аргумент C2:C3 (или перетащите его, чтобы выбрать ячейки).
  5. Введите закрываюю скобки )и нажмите ввод.

Каждый аргумент может быть диапазоном, числом или ссылками на отдельные ячейки, разделенными запятой.

  • =СУММ(A2:A4;2429;10482)
  • =СУММ(4823;A3:A4;C2:C3)
  • =СУММ(4823;12335;9718;C2:C3)
  • =СУММ(A2;A3;A4;2429;10482)

Совет: Если вам нужно свести столбцы или строки чисел рядом друг с другом, используйте авто сумму чисел.

Попробуйте попрактиковаться

Если вы хотите поиграть с образцом данных, воспользуйтесь некоторыми данными.

Чтобы узнать, как работает функция СУММ, скопируйте таблицу ниже в таблицу и вкопируйте ее в ячейку A1.

Способы добавления значений в электронную таблицу

Одним из быстрых и простых способов добавления значений в Excel является использование автосуммы. Просто выберите пустую ячейку непосредственно под столбцом данных. Затем на вкладке Формула щелкните Автосумма > Сумма. Excel будет автоматически определить диапазон для суммы. (Автосумма также может работать по горизонтали при выборе пустой ячейки справа от ячеек для суммирования.)

AutoSum создает формулу для вас, чтобы вам не нужно было вводить текст. Однако если вы предпочитаете вводить формулу самостоятельно, см. функцию СУММ.

Добавление на основе условий

  • Используйте функцию СУММЕСЛИ , если требуется суммировать значения с одним условием. Например, если необходимо сложить общий объем продаж определенного продукта.
  • Используйте функцию SUMIFS , если требуется суммировать значения с несколькими условиями. Например, может потребоваться сложить общий объем продаж определенного продукта в пределах определенного региона продаж.

Сложение или вычитание дат

Общие сведения о том, как добавлять или вычитать даты, см. в разделе Добавление или вычитание дат. Более сложные вычисления даты см. в разделе Функции даты и времени.

Сложение и вычитание значений времени

Общие сведения о том, как добавлять или вычитать время, см. в статье Добавление или вычитание времени. Другие вычисления времени см. в разделе Функции даты и времени.

Дополнительные сведения

Вы всегда можете задать вопрос эксперту в Excel Tech Community или получить поддержку в сообществах.

Использование функции «Автосумма» для суммирования чисел

Excel для Microsoft 365 Excel для Microsoft 365 для Mac Excel для Интернета Excel 2021 Excel 2021 для Mac Excel 2019 Excel 2019 для Mac Excel 2016 Excel 2013 Excel для iPad Excel для iPhone Excel для планшетов с Android Excel для телефонов с Android Еще. Меньше

Если вам нужно подвести итоги по столбцу или строке чисел, разрешите Excel выполнить математические вычисления за вас. Выберите ячейку рядом с числами, которые нужно суммировать, нажмите кнопку Автосумма на вкладке Главная , нажмите клавишу ВВОД, и все готово.

Кнопка

Когда вы нажимаете кнопку Автосумма, Excel автоматически вводит формулу для суммирования чисел (в которой используется функция СУММ).

Приведем пример. Чтобы добавить числа января в этот бюджет развлечения, выберите ячейку B7, ячейку непосредственно под столбцом чисел. Затем щелкните Автосумма. В ячейке B7 появится формула, а Excel выделяет ячейки, которые вы суммируете.

Формула, созданная нажатием кнопки «Автосумма» на вкладке «Главная»

Чтобы отобразить результат (95,94) в ячейке В7, нажмите клавишу ВВОД. Формула также отображается в строке формул вверху окна Excel.

Результат автосуммирования в ячейке В7

  • Чтобы сложить числа в столбце, выберите ячейку под последним числом в столбце. Чтобы сложить числа в строке, выберите первую ячейку справа.
  • Автосумма находится в двух расположениях: домашняя >автосумма и формула >автосуммы.
  • Создав формулу один раз, ее можно копировать в другие ячейки, а не вводить снова и снова. Например, при копировании формулы из ячейки B7 в ячейку C7 формула в ячейке C7 автоматически настроится под новое расположение и подсчитает числа в ячейках C3:C6.
  • Кроме того, вы можете использовать функцию «Автосумма» сразу для нескольких ячеек. Например, можно выделить ячейки B7 и C7, нажать кнопку Автосумма и суммировать два столбца одновременно.
  • Также вы можете суммировать числа путем создания простых формул.

Если вам нужно подвести итоги по столбцу или строке чисел, разрешите Excel выполнить математические вычисления за вас. Выберите ячейку рядом с числами, которые нужно суммировать, нажмите кнопку Автосумма на вкладке Главная , нажмите клавишу ВВОД, и все готово.

Автосумма macOS

Когда вы нажимаете кнопку Автосумма, Excel автоматически вводит формулу для суммирования чисел (в которой используется функция СУММ).

Приведем пример. Чтобы добавить числа января в этот бюджет развлечения, выберите ячейку B7, ячейку непосредственно под столбцом чисел. Затем щелкните Автосумма. В ячейке B7 появится формула, а Excel выделяет ячейки, которые вы суммируете.

Ячейка автосуммы macOS

Чтобы отобразить результат (95,94) в ячейке В7, нажмите клавишу ВВОД. Формула также отображается в строке формул вверху окна Excel.

Формула автосуммы macOS

  • Чтобы сложить числа в столбце, выберите ячейку под последним числом в столбце. Чтобы сложить числа в строке, выберите первую ячейку справа.
  • Автосумма находится в двух расположениях: домашняя >автосумма и формула >автосуммы.
  • Создав формулу один раз, ее можно копировать в другие ячейки, а не вводить снова и снова. Например, при копировании формулы из ячейки B7 в ячейку C7 формула в ячейке C7 автоматически настроится под новое расположение и подсчитает числа в ячейках C3:C6.
  • Кроме того, вы можете использовать функцию «Автосумма» сразу для нескольких ячеек. Например, можно выделить ячейки B7 и C7, нажать кнопку Автосумма и суммировать два столбца одновременно.
  • Также вы можете суммировать числа путем создания простых формул.

На планшете или телефоне с Android

Автосумма в Excel на планшете с Android

  1. На листе коснитесь первой пустой ячейки после диапазона ячеек с числами или выделите необходимый диапазон ячеек касанием и перемещением пальца.

Автосумма в Excel на планшете с Android

Коснитесь элемента Автосумма.

Сумма в Excel на планшете с Android

Нажмите Сумма.

Флажок

Коснитесь флажка.

Сумма получена

Готово!

Если вам нужно подвести итоги по столбцу или строке чисел, разрешите Excel выполнить математические вычисления за вас. Выберите ячейку рядом с числами, которые нужно суммировать, нажмите кнопку Автосумма на вкладке Главная , нажмите клавишу ВВОД, и все готово.

Excel для веб-автосуммы

Когда вы нажимаете кнопку Автосумма, Excel автоматически вводит формулу для суммирования чисел (в которой используется функция СУММ).

Приведем пример. Чтобы добавить числа января в этот бюджет развлечения, выберите ячейку B7, ячейку непосредственно под столбцом чисел. Затем щелкните Автосумма. В ячейке B7 появится формула, а Excel выделяет ячейки, которые вы суммируете.

Excel для ячейки веб-автосуммы

Чтобы отобразить результат (95,94) в ячейке В7, нажмите клавишу ВВОД. Формула также отображается в строке формул вверху окна Excel.

Excel для формулы автосуммы в Интернете

  • Чтобы сложить числа в столбце, выберите ячейку под последним числом в столбце. Чтобы сложить числа в строке, выберите первую ячейку справа.
  • Автосумма находится в двух расположениях: домашняя >автосумма и формула >автосуммы.
  • Создав формулу один раз, ее можно копировать в другие ячейки, а не вводить снова и снова. Например, при копировании формулы из ячейки B7 в ячейку C7 формула в ячейке C7 автоматически настроится под новое расположение и подсчитает числа в ячейках C3:C6.
  • Кроме того, вы можете использовать функцию «Автосумма» сразу для нескольких ячеек. Например, можно выделить ячейки B7 и C7, нажать кнопку Автосумма и суммировать два столбца одновременно.
  • Также вы можете суммировать числа путем создания простых формул.

Дополнительные сведения

Вы всегда можете задать вопрос эксперту в Excel Tech Community или получить поддержку в сообществах.

СУММ (функция СУММ)

Функция СУММ добавляет значения. Вы можете складывать отдельные значения, диапазоны ячеек, ссылки на ячейки или данные всех этих трех видов.

  • =СУММ(A2:A10) Добавляет значения в ячейки A2:10.
  • =СУММ(A2:A10;C2:C10) Добавляет значения в ячейки A2:10, а также ячейки C2:C10.

Ваш браузер не поддерживает видео. Установите Microsoft Silverlight, Adobe Flash Player или Internet Explorer 9.

СУММ(число1;[число2];…)

Имя аргумента

Первое число для сложения. Это может быть число 4, ссылка на ячейку, например B6, или диапазон ячеек, например B2:B8.

Это второе число для сложения. Можно указать до 255 чисел.

Рекомендации по использованию функции СУММ

Этот раздел содержит некоторые рекомендации по работе с функцией СУММ. Многие из этих рекомендаций можно применить и к другим функциям.

Метод =1+2 или =A+B. Вы можете ввести =1+2+3 или =A1+B1+C2 и получить абсолютно точные результаты, однако этот метод ненадежен по ряду причин.

  1. Опечатки. Допустим, вы пытаетесь ввести много больших значений такого вида:
    • =14598,93+65437,90+78496,23

А теперь попробуйте проверить правильность записей. Гораздо проще поместить эти значения в отдельные ячейки и использовать их в формуле СУММ. Кроме того, значения в ячейках можно отформатировать, чтобы привести их к более наглядному виду, чем если бы они были в формуле.

Используйте функцию СУММ, вместо того чтобы указывать значения прямо в формулах. Ячейка D5 содержит формулу =СУММ(D2:D4)

  • =A1+B1+C1 или =A1+A2+A3

Пример неудачной формулы. Ячейка D2 содержит формулу =A2+B2+C2

Если ячейки, на которые указывают ссылки, содержат нечисловые (текстовые) значения, формула может вернуть ошибку #ЗНАЧ!. Функция СУММ пропускает текстовые значения и выдает сумму только числовых значений.

Правильная формула. Вместо выражения =A2+B2+C2 ячейка D2 содержит формулу =СУММ(A2:C2)

Ошибка #ССЫЛКА! возникла из-за удаления столбца. Формула приняла вид =A2+#ССЫЛКА!+B2

Ошибка #ССЫЛКА! при удалении строк или столбцов

Функция СУММ будет автоматически корректироваться при вставке и удалении строк и столбцов.

При удалении строки или столбца формулы не обновляются: из них не исключаются удаленные значения, поэтому возвращается ошибка #ССЫЛКА!. Функция СУММ, в свою очередь, обновляется автоматически.

Формулы =A+B+C не обновляются при добавлении строк

Формулы не обновляют ссылки при вставке строк или столбцов

В примере показана формула СУММ, которая при добавлении столбца автоматически расширяется от =СУММ(A2:C2) до =СУММ(A2:D2)

При вставке строки или столбца формула не обновляется — в нее не включается добавленная строка, тогда как функция СУММ будет автоматически обновляться (пока вы не вышли за пределы диапазона, на который ссылается формула). Это особенно важно, когда вы рассчитываете, что формула обновится, но этого не происходит. В итоге ваши результаты остаются неполными, и этого можно не заметить.

  • =СУММ(A1;A2;A3;B1;B2;B3)

вы изначально закладываете в нее вероятность появления ошибок при вставке или удалении строк в указанном диапазоне по тем же причинам. Гораздо лучше использовать отдельные диапазоны, например:

Такая формула будет обновляться при добавлении и удалении строк.

Вопросы и ответы

Расчет времени

  1. Мне нужно добавить, вычесть, умножить или поделить числа. Просмотрите серию учебных видео: Основные математические операции в Excel или Использование Microsoft Excel в качестве калькулятора.
  2. Как уменьшить или увеличить число отображаемых десятичных знаков? Можно изменить числовой формат. Выберите соответствующую ячейку или соответствующий диапазон и нажмите клавиши CTRL+1, чтобы открыть диалоговое окно Формат ячеек, затем щелкните вкладку Число и выберите нужный формат, указав при этом нужное количество десятичных знаков.
  3. Как добавить или вычесть значения времени? Есть несколько способов добавить или вычесть значения времени. Например, чтобы получить разницу между 8:00 и 12:00 для вычисления заработной платы, можно воспользоваться формулой =(«12:00»-«8:00»)*24, т. е. отнять время начала от времени окончания. Обратите внимание, что Excel вычисляет значения времени как часть дня, поэтому чтобы получить суммарное количество часов, необходимо умножить результат на 24. В первом примере используется формула =((B2-A2)+(D2-C2))*24 для вычисления количества часов от начала до окончания работы с учетом обеденного перерыва (всего 8,5 часов). Если вам нужно просто добавить часы и минуты, вы можете просто вычислить сумму, не умножая ее на 24. Во втором примере используется формула =СУММ(A6:C6), так как здесь нужно просто посчитать общее количество часов и минут, затраченных на задания (5:36, т. е. 5 часов 36 минут).

Вычисление разницы между датами

Дополнительные сведения см. в статье Сложение и вычитание значений времени
Как получить разницу между датами? Как и значения времени, значения дат можно добавить или вычесть. Вот распространенный пример вычисления количества дней между датами. Для этого используется простая формула =B2-A2. При работе со значениями дат и времени важно помнить, что дата или время начала вычитается из даты или времени окончания.

Дополнительные сведения

Вы всегда можете задать вопрос эксперту в Excel Tech Community или получить поддержку в сообществах.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *