Как посмотреть количество символов в ячейке excel
Перейти к содержимому

Как посмотреть количество символов в ячейке excel

  • автор:

Как подсчитать количество символов в ячейке MS Excel?

Для подсчёта количество символов в ячейке Microsoft Excel используйте функцию ДЛСТР.

Текстовая функция ДЛСТР возвращает количество знаков в текстовой строке (с учётом пробелов). Например, если ячейка А3 содержит «Какой-то текст«, формула =ДЛСТР(A3) в качестве результата возвращает челое число 14.

Аргументом функции может выступать и строка символов, заключенная в двойные кавычки. Применительно к предыдущему примеру, формула будет выглядеть так: =ДЛСТР(«Какой-то текст«).

При использовании функции ДЛСТР со значением она возвращает количество символов в числе, которое может отличаться от количества символов, отображаемых в результате форматирования чисел, поскольку в качестве результата возвращается длина отображаемого текста или значения, а не хранимого значения ячейки. Этот нюанс проявляется, например, в том случае, когда функция игнорирует незначащие нули у значения, введенного в ячейку, но впоследствии автоматически отформатированного в соответствии с указанными пользователем настройками.

© 2013-2024 «Очень Просто» (www.verysimple.ru)

Подсчет количества определенных символов в ячейке excel

Функция =СЧЁТСИМВЛ(ТЕКСТ, СИМВОЛ) имеет два обязательных аргумента:

  • ТЕКСТ — Строка, в которой необходимо посчитать количество символов.
  • ШАБЛОН — Символ, который необходимо посчитать.

Если вы забыли синтаксис данной функции, вы всегда сможете вызвать формулу из выпадающего списка функций в надстройке.

Теперь к практике. Далее привожу множество примеров использования данной функции.

Пример 1

Посчитать количество пробелов в тексте.

Пример 2

Посчитать количество заданных символов.

Пример 3

Посчитать количество символов не обращая внимание на регистр.

Пример 4

Посчитать количество слов в тексте.

Пример 5

Посчитать количество слов в тексте не обращая внимания на двойные пробелы.

Пример 6

Посчитать количество всех символов в строке за исключением пробелов.

Альтернатива данной функции

Excel позволяет пользователям достичь правильного решения разными путями. Данная формула не исключение. Заменить данную функцию можно с помощью двух других: ДЛСТР и ПОДСТАВИТЬ. Чтобы определить количество заданного символа сначала определите длину всего текста функцией ДЛСТР, а затем отнимите от этого значения длину этого же текста, только с предварительно удаленными символами (которые вы ищите): =ДЛСТР(B13)-ДЛСТР(ПОДСТАВИТЬ(B13;» «;»»)). В файле для скачивания приведены конкретные примеры.

Код на VBA

Function СЧЁТСИМВЛ(ТЕКСТ As String, СИМВОЛ As String) As Long Dim i As Long Dim S As Long S = 0 For i = 1 To Len(ТЕКСТ) If СИМВОЛ = Mid(ТЕКСТ, i, 1) Then S = S + 1 Next СЧЁТСИМВЛ = S End Function

Надстройка
VBA-Excel

Надстройка для Excel содержит большой набор полезных функций, с помощью которых вы значительно сократите время и увеличите скорость работы с программой.

Как посмотреть количество символов в ячейке excel

Argument ‘Topic id’ is null or empty

Сейчас на форуме

© Николай Павлов, Planetaexcel, 2006-2023
info@planetaexcel.ru

Использование любых материалов сайта допускается строго с указанием прямой ссылки на источник, упоминанием названия сайта, имени автора и неизменности исходного текста и иллюстраций.

ООО «Планета Эксел»
ИНН 7735603520
ОГРН 1147746834949
ИП Павлов Николай Владимирович
ИНН 633015842586
ОГРНИП 310633031600071

Подсчет символов в ячейках

Если необходимо подсчитать символы в ячейках, используйте функцию LEN, которая подсчитывает буквы, цифры, символы и все пробелы. Например, длина фразы «На улице сегодня 25 градусов, я пойду купаться» (не учитывая кавычки) составляет 46 символов: 36 букв, 2 цифры, 7 пробелов и запятая.

Чтобы использовать функцию, введите =LEN(cell) в строке формул, а затем нажмите клавишу ВВОД на клавиатуре.

Несколько ячеек: Чтобы применить одну и ту же формулу к нескольким ячейкам, введите формулу в первую ячейку, а затем перетащите маркер заполнения вниз (или поперек) диапазона ячеек.

Ввод нескольких функций ДЛСТР на листе

Чтобы получить общее количество всех символов в нескольких ячейках, необходимо использовать функции СУММ вместе с LEN. В этом примере функция LEN подсчитывает символы в каждой ячейке, а функция СУММ добавляет счетчики:

=СУММ((LEN( cell1 ),LEN( cell2 ),(LEN( cell3 )) ))).

Попробуйте попрактиковаться

Ниже приведены некоторые примеры использования функции LEN.

Скопируйте приведенную ниже таблицу и вставьте ее в ячейку A1 на листе Excel. Перетащите формулу из B2 в B4, чтобы увидеть длину текста во всех ячейках столбца A.

Текстовые строки

Быстрая бурая лиса.

Быстрая бурая лиса вскочила.

Съешь же еще этих мягких французских булок, да выпей чаю.

Подсчет символов в одной ячейке

  1. Щелкните ячейку B2.
  2. Введите =LEN(A2).

Формула подсчитывает символы в ячейке A2, которая составляет 27, включая все пробелы и точку в конце предложения.

ПРИМЕЧАНИЕ: LEN подсчитывает пробелы после последнего символа.

Подсчет символов в нескольких ячейках

  1. Щелкните ячейку B2.
  2. Нажмите клавиши CTRL+C, чтобы скопировать ячейку B2, затем выделите ячейки B3 и B4, а затем нажмите клавиши CTRL+V, чтобы вставить формулу в ячейки B3:B4.

При этом формула копируется в ячейки B3 и B4, а функция подсчитывает символы в каждой ячейке (20, 27 и 45).

Подсчет общего количества символов

  1. В книге с примерами щелкните ячейку В6.
  2. Введите в ячейке формулу =СУММ(ДЛСТР(A2);ДЛСТР(A3);ДЛСТР(A4)) и нажмите клавишу ВВОД.

Это подсчитывает символы в каждой из трех ячеек и суммирует их (92).

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *