Как проверить в экселе повторяющиеся значения в одном столбце
Перейти к содержимому

Как проверить в экселе повторяющиеся значения в одном столбце

  • автор:

Поиск и удаление дубликатов в Excel

Задача поиска повторяющихся значений в таблице Excel часто встречается. Иногда бывает, что дубликаты нужно просто найти, чтобы просто узнать какие именно данные повторяются, не удаляя их, а иногда бывает, что нужно именно удалить дубликаты, оставив повторяющиеся значения в одном экземпляре. В интернете есть много способов как выполнить эти задачи, но на мой взгляд ни к чему много способов — достаточно по одному простому, который легко сделать без всяких заморочек.

Чтобы показать 3 самых простых способа поиска и удаления дубликатов, использую такую таблицу:

Итак, теперь на этом примере покажу какой алгоритм действий.

Найти повторяющиеся значения в таблице Excel

Самый простой способ найти дубликаты на мой взгляд — это использовать «Условное форматирование» для выделения цветом повторов и потом отфильтровать их.

Для этого сначала выделите всю таблицу с вашими данными и затем нажмите как показано на рисунке:

И в появившемся окне нажмите «Ок»

Excel окрасит повторяющиеся значения и получится такой:

Если данных не много, то уже этого вполне достаточно, чтобы определить какие данные повторяются.

Если таблица с данными очень большая , то чтобы не пропустить дубли, можно просто поставить фильтр по цвету.

Для этого снова выделяем всю таблицу и нажимаем кнопку «Фильтр».

Теперь в таблице, нужно применить сортировку, либо фильтр по цвету:

В результате мы получим только те значения, которые повторяются более одного раза:

Еще один простой способ найти повторяющиеся значения — это использовать формулу для подсчета повторов. Она будет довольно простая для нашего примера таблицы: СЧЁТЕСЛИ(B:B;B2) , где первый аргумент (B:B) — это диапазон для подсчета количества ячеек, а второй аргумент (B2) — это ячейка, совпадение с которой ищем (критерий поиска).

Таким образом, получаем таблицу с колонкой, в которой посчитано количество повторов и остается лишь отфильтровать таблицу по этой колонке.

Удалить дубли в таблице Excel

Решить эту задачу можно еще гораздо проще, чем найти повторы. Для этого у Excel-я есть соответствующий инструмент «Удалить дубликаты» в закладке «Данные».

В появившемся окне нужно отметить столбец, в котором Excel должен проверить наличие повторяющихся значений.

После нажатия «ОК» строки с дубликатами будут удалены, при этом те значения, которые повторялись, теперь будут в одном экземпляре.

Как найти одинаковые значения в столбце Excel

Поиск дублей в Excel – это одна из самых распространенных задач для любого офисного сотрудника. Для ее решения существует несколько разных способов. Но как быстро как найти дубликаты в Excel и выделить их цветом? Для ответа на этот часто задаваемый вопрос рассмотрим конкретный пример.

Как найти повторяющиеся значения в Excel?

Допустим мы занимаемся регистрацией заказов, поступающих на фирму через факс и e-mail. Может сложиться такая ситуация, что один и тот же заказ поступил двумя каналами входящей информации. Если зарегистрировать дважды один и тот же заказ, могут возникнуть определенные проблемы для фирмы. Ниже рассмотрим решение средствами условного форматирования.

Список закзов.

Чтобы избежать дублированных заказов, можно использовать условное форматирование, которое поможет быстро найти одинаковые значения в столбце Excel.

Пример дневного журнала заказов на товары:

Чтобы проверить содержит ли журнал заказов возможные дубликаты, будем анализировать по наименованиям клиентов – столбец B:

  1. Выделите диапазон B2:B9 и выберите инструмент: «ГЛАВНАЯ»-«Стили»-«Условное форматирование»-«Создать правило». Создать правило.
  2. Вберете «Использовать формулу для определения форматируемых ячеек». Формула.
  3. Чтобы найти повторяющиеся значения в столбце Excel, в поле ввода введите формулу: =СЧЁТЕСЛИ($B$2:$B$9; B2)>1. Зеленый.
  4. Нажмите на кнопку «Формат» и выберите желаемую заливку ячеек, чтобы выделить дубликаты цветом. Например, зеленый. И нажмите ОК на всех открытых окнах.

Дубликаты.

Как видно на рисунке с условным форматированием нам удалось легко и быстро реализовать поиск дубликатов в Excel и обнаружить повторяющиеся данные ячеек для таблицы журнала заказов.

Пример функции СЧЁТЕСЛИ и выделение повторяющихся значений

Принцип действия формулы для поиска дубликатов условным форматированием – прост. Формула содержит функцию =СЧЁТЕСЛИ(). Эту функцию так же можно использовать при поиске одинаковых значений в диапазоне ячеек. В функции первым аргументом указан просматриваемый диапазон данных. Во втором аргументе мы указываем что мы ищем. Первый аргумент у нас имеет абсолютные ссылки, так как он должен быть неизменным. А второй аргумент наоборот, должен меняться на адрес каждой ячейки просматриваемого диапазона, потому имеет относительную ссылку.

Самые быстрые и простые способы: найти дубликаты в ячейках.

После функции идет оператор сравнения количества найденных значений в диапазоне с числом 1. То есть если больше чем одно значение, значит формула возвращает значение ИСТЕНА и к текущей ячейке применяется условное форматирование.

  • Создать таблицу
  • Форматирование
  • Функции Excel
  • Формулы и диапазоны
  • Фильтр и сортировка
  • Диаграммы и графики
  • Сводные таблицы
  • Печать документов
  • Базы данных и XML
  • Возможности Excel
  • Настройки параметры
  • Уроки Excel
  • Макросы VBA
  • Скачать примеры

Как проверить в экселе повторяющиеся значения в одном столбце

Argument ‘Topic id’ is null or empty

Сейчас на форуме

© Николай Павлов, Planetaexcel, 2006-2023
info@planetaexcel.ru

Использование любых материалов сайта допускается строго с указанием прямой ссылки на источник, упоминанием названия сайта, имени автора и неизменности исходного текста и иллюстраций.

ООО «Планета Эксел»
ИНН 7735603520
ОГРН 1147746834949
ИП Павлов Николай Владимирович
ИНН 633015842586
ОГРНИП 310633031600071

Как проверить в экселе повторяющиеся значения в одном столбце

Argument ‘Topic id’ is null or empty

Сейчас на форуме

© Николай Павлов, Planetaexcel, 2006-2023
info@planetaexcel.ru

Использование любых материалов сайта допускается строго с указанием прямой ссылки на источник, упоминанием названия сайта, имени автора и неизменности исходного текста и иллюстраций.

ООО «Планета Эксел»
ИНН 7735603520
ОГРН 1147746834949
ИП Павлов Николай Владимирович
ИНН 633015842586
ОГРНИП 310633031600071

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *