Как поставить плюс в excel без формулы
Перейти к содержимому

Как поставить плюс в excel без формулы

  • автор:

Как поставить плюс в excel без формулы

Argument ‘Topic id’ is null or empty

Сейчас на форуме

© Николай Павлов, Planetaexcel, 2006-2023
info@planetaexcel.ru

Использование любых материалов сайта допускается строго с указанием прямой ссылки на источник, упоминанием названия сайта, имени автора и неизменности исходного текста и иллюстраций.

ООО «Планета Эксел»
ИНН 7735603520
ОГРН 1147746834949
ИП Павлов Николай Владимирович
ИНН 633015842586
ОГРНИП 310633031600071

Как поставить плюс перед числом в Excel

Если добавить + перед положительным числом, то Excel его очистить. В данной статье расскажем как заставить Excel этого не делать.

Причина такого поведения заключается в том, что Excel считает плюс избыточными и приводит числа в формат по умолчанию. Но иногда вам может понадобиться добавить знак плюс перед числом. Особенно это важно, когда необходимо показать изменения результата.

Другим распространенным вариантом использования этого является, когда вы хотите знак плюс перед номером телефона. Как сделать телефонный формат подробно описано в этой статье.

Давайте разберем несколько способов добавления знака «+» перед числом

Использование пользовательского числового формата

Вы можете создать собственный числовой формат для ячеек с положительными значениями. Само значение так и останется в числовом формате и вы сможете производить вычисления с этими ячейками. Это просто изменит форматирование и вывод числа на экран.

Предположим, у вас есть набор данных, как показано ниже, и вы хотите добавить знак плюс перед всеми положительными числами:

Данные в которых необходимо указать плюс перед положительными числами

Пошаговая инструкция как это сделать:

  1. Выберите ячейки с числами, в которых необходимо поставить знак плюс.
  2. Щелкните правой кнопкой мыши, а затем выберите Формат ячеек
    Щелкните правой кнопкой мыши, а затем выберите Формат ячеек
  3. В диалоговом окне «Формат ячеек» на вкладке «Число» выберите категорию «Все форматы».
    В диалоговом окне «Формат ячеек» на вкладке «Число» выберите категорию «Все форматы»
  4. В поле Тип введите следующее значение: +# ##0;-# ##0
  5. Нажмите на ОК.

Вы заметите, что знак плюс был добавлен к положительным числам, а все остальное остается прежним.

Плюс перед положительными числами

Обратите внимание, что это фактическое значение ячейки не изменилось. Например, значение в ячейке D2 по-прежнему равно 5100. Оно просто отображается в виде числа со знаком плюс перед ним.

Также, как и любое другое форматирование, вы можете скопировать и вставить этот формат в другие ячейки. Просто копируйте нужные ячейки, формат также будет скопирован. Или воспользуйтесь функцией формат по образцу.

Другие полезные пользовательские форматы

Положительные числа со знаком плюс и отрицательными числами в скобках: +# ##0;(# ##0)

Положительные числа со знаком плюс и отрицательными числами красного цвета: +0; [Красный] -0

Положительные числа в зеленом и отрицательные числа в красном: [Зеленый] +0; [Красный] -0

Добавление знака плюс перед положительными числами вручную

В некоторых случаях, если у вас есть только несколько ячеек, в которые нужно добавить знак плюс перед положительным числом, быстрым способом будет просто добавить апостроф, а затем добавить знак плюс.

Добавление апострофа преобразует содержимое ячейки в текст, поэтому, когда вы добавляете знак плюс, он прикрепляется. Кроме того, сам апостроф не отображается на экране или при печати.

Единственный минус такого подхода в том, что дальнейшие вычисления с числом невозможны, так как это уже текстовая ячейка.

Как поставить плюс минус равно в Excel

Обычно знаки =,-,+ в Excel используются для формул, и многие не знают как их можно поставить в виде обычного текста. В этой статье мы расскажем подробно как можно поставить плюс, минус или равно и другие знаки в программе Microsoft Excel.

Для начала найдем на русской клавиатуре букву «Э», но Вам нужна английская раскладка, на английской раскладке это будет символ (половина кавычки) Поставив этот символ должно получится вот так:

Как сделать формулу текстом в Excel

Дальше выбираем любой знак формулы ровно (=), минус (-), плюс (+) и ставим его после (половина ковычки, буква Э)

Вставка расно в

Как показано на картинке Выше. Далее клавиша Enter, или просто перейдите на другую ячейку.

Все готово. Теперь мы сможем скопировать столько знаков плюс, минус или равно сколько нам нужно,

CTRL+C — скопировать ячейку

CTRL+V — вставить ячейку

Также ячейку можно скопировать правой кнопкой мыши, выберите копировать

Дополнительно: знак / по умолчанию используется в настройках как переход в меню, чтобы его вставить провалитесь в ячейку щелкнув по ней, или поменяйте его на другое значение зайдя в файл, параметры, дополнительно (в самом низу)

Функция ТЕКСТ

С помощью функции ТЕКСТ можно изменить представление числа, применив к нему форматирование с кодами форматов. Это полезно в ситуации, когда нужно отобразить числа в удобочитаемом виде либо объединить их с текстом или символами.

Примечание: Функция TEXT преобразует числа в текст, что может затруднить ссылку в последующих вычислениях. Лучше сохранить исходное значение в одной ячейке, а затем использовать функцию TEXT в другой ячейке. Затем, если потребуется создать другие формулы, всегда ссылайтесь на исходное значение, а не на результат функции ТЕКСТ.

Технические сведения

ТЕКСТ(значение; формат)

Аргументы функции ТЕКСТ описаны ниже.

Имя аргумента

Числовое значение, которое нужно преобразовать в текст.

Текстовая строка, определяющая формат, который требуется применить к указанному значению.

Общие сведения

Самая простая функция ТЕКСТ означает следующее:

  • =ТЕКСТ(значение, которое нужно отформатировать; «код формата, который требуется применить»)

Ниже приведены популярные примеры, которые вы можете скопировать прямо в Excel, чтобы поэкспериментировать самостоятельно. Обратите внимание: коды форматов заключены в кавычки.

=ТЕКСТ(1234,567;«# ##0,00 ₽»)

Денежный формат с разделителем групп разрядов и двумя разрядами дробной части, например: 1 234,57 ₽. Обратите внимание: Excel округляет значение до двух разрядов дробной части.

=ТЕКСТ(СЕГОДНЯ();«ДД.ММ.ГГ»)

Сегодняшняя дата в формате ДД/ММ/ГГ, например: 14.03.12

=ТЕКСТ(СЕГОДНЯ();«ДДДД»)

Сегодняшний день недели, например: понедельник

=ТЕКСТ(ТДАТА();«ЧЧ:ММ»)

Текущее время, например: 13:29

=ТЕКСТ(0,285;«0,0 %»)

Процентный формат, например: 28,5 %

Дробный формат, например: 4 1/3

=СЖПРОБЕЛЫ(ТЕКСТ(0,34;«# ?/?»))

Дробный формат, например: 1/3 Обратите внимание: функция СЖПРОБЕЛЫ используется для удаления начального пробела перед дробной частью.

=ТЕКСТ(12200000;«0,00E+00»)

Экспоненциальное представление, например: 1,22E+07

Дополнительный формат (номер телефона), например: (123) 456-7898

=ТЕКСТ(1234;«0000000»)

Добавление нулей в начале, например: 0001234

=ТЕКСТ(123456;«##0° 00′ 00»»)

Пользовательский формат (широта или долгота), например: 12° 34′ 56»

Примечание: Функцию ТЕКСТ можно использовать для изменения форматирования, но это не единственный способ. Вы можете изменить формат без формулы, нажав клавиши CTRL+1 (или

Изображение значка кнопки команд в Mac

+1 на компьютере Mac), а затем выберите нужный формат в диалоговом окне Формат ячеек > число .

Скачивание образцов

Предлагаем скачать книгу, в которой содержатся все примеры применения функции ТЕКСТ из этой статьи и несколько других. Вы можете воспользоваться ими или создать собственные коды форматов для функции ТЕКСТ.

Другие доступные коды форматов

С помощью диалогового окна Формат ячеек можно найти другие доступные коды форматирования:

Изображение значка кнопки команд в Mac

    Нажмите клавиши CTRL+1 (

Коды форматов по категориям

Ниже приведены некоторые примеры того, как можно применить различные числовые форматы к значениям с помощью диалогового окна Формат ячеек , а затем с помощью параметра Custom скопировать эти коды форматирования в функцию TEXT .

Выбор числового формата

  • Выбор числового формата
  • Нули в начале
  • Разделитель групп разрядов.
  • Числовые, денежные и финансовые форматы
  • Даты
  • Значения времени
  • Проценты
  • Дроби
  • Экспоненциальное представление
  • Дополнительные форматы

Почему программа Excel удаляет нули в начале?

Excel воспринимает последовательность цифр, введенную в ячейку, как число, а не как цифровой код, например артикул или номер SKU. Чтобы сохранить нули в начале последовательностей цифр, перед вставкой или вводом значений примените к соответствующему диапазону ячеек текстовый формат. Выделите столбец или диапазон, в который нужно поместить значения, нажмите клавиши CTRL+1, чтобы открыть диалоговое окно Формат ячеек, и выберите на вкладке Число пункт Текстовый. Теперь программа Excel не будет удалять нули в начале.

Если вы уже ввели данные и Excel удалил начальные нули, вы можете снова добавить их с помощью функции ТЕКСТ. Создайте ссылку на верхнюю ячейку со значениями и используйте формат =ТЕКСТ(значение;»00000″), где число нулей представляет нужное количество символов. Затем скопируйте функцию и примените ее к остальной части диапазона.

Примеры использования функции ТЕКСТ для добавления начальных нулей: =ТЕКСТ(A2;

Если по какой-либо причине потребуется преобразовать текстовые значения обратно в числа, можно умножить их на 1 (например: =D4*1) или воспользоваться двойным унарным оператором (—), например: =—D4.

В Excel группы разрядов разделяются пробелом, если код формата содержит пробел, окруженный знаками номера (#) или нулями. Например, если используется код формата «# ###», число 12200000 отображается как 12 200 000.

Пробел после заполнителя цифры задает деление числа на 1000. Например, если используется код формата «# ###,0 «, число 12200000 отображается в Excel как 12 200,0.

Примеры функции ТЕКСТ с разделителем групп разрядов

  • Разделитель групп разрядов зависит от региональных параметров. Для России это пробел, но в других странах и регионах может использоваться запятая или точка.
  • Разделитель групп разрядов можно применять в числовых, денежных и финансовых форматах.

Ниже показаны примеры стандартных числовых (только с разделителем групп разрядов и десятичными знаками), денежных и финансовых форматов. В денежном формате можно добавить нужное обозначение денежной единицы, и значения будут выровнены по нему. В финансовом формате символ рубля располагается в ячейке справа от значения (если выбрать обозначение доллара США, то эти символы будут выровнены по левому краю ячеек, а значения — по правому). Обратите внимание на разницу между кодами денежных и финансовых форматов: в финансовых форматах для отделения символа денежной единицы от значения используется звездочка (*).

Примеры функции ТЕКСТ с числовыми, денежными и финансовыми форматами

Чтобы получить код формата для определенной денежной единицы, сначала нажмите клавиши CTRL+1 (на компьютере Mac —

Изображение значка кнопки команд в Mac

+1) и выберите нужный формат, а затем в раскрывающемся списке Обозначение выберите символ.

Выбор обозначения денежной единицы в диалоговом окне

После этого в разделе Числовые форматы слева выберите пункт (все форматы) и скопируйте код формата вместе с обозначением денежной единицы.

Функция ТЕКСТ — пользовательский денежный формат с обозначением денежной единицы

Примечание: Функция ТЕКСТ не поддерживает форматирование с помощью цвета. Если скопировать в диалоговом окне «Формат ячеек» код формата, в котором используется цвет, например «# ##0,00 ₽;[Красный]# ##0,00 ₽», то функция ТЕКСТ воспримет его, но цвет отображаться не будет.

Способ отображения дат можно изменять, используя сочетания символов «Д» (для дня), «М» (для месяца) и «Г» (для года).

Коды форматов для месяца, дня и года

В функции ТЕКСТ коды форматов используются без учета регистра, поэтому допустимы символы «М» и «м», «Д» и «д», «Г» и «г».

Минда Триси (Mynda Treacy), Excel MVP

Минда советует.

Если вы предоставляете общий доступ к файлам и отчетам Excel пользователям из разных стран, скорее всего, потребуется, чтобы они были на разных языках. Минда Триси (Mynda Treacy), Excel MVP, предлагает отличное решение этой задачи в своей статье Отображение дат Excel на разных языках (на английском). В ней также есть пример книги, который вы можете скачать.

Способ отображения времени можно изменить с помощью сочетаний символов «Ч» (для часов), «М» (для минут) и «С» (для секунд). Кроме того, для представления времени в 12-часовом формате можно использовать символы «AM/PM».

Форматы времени (часы, минуты и секунды)

Если не указывать символы «AM/PM», время будет отображаться в 24-часовом формате.

В функции ТЕКСТ коды форматов используются без учета регистра, поэтому допустимы символы «Ч» и «ч», «М» и «м», «С» и «с», «AM/PM» и «am/pm».

Для отображения десятичных значений можно использовать процентные (%) форматы.

Коды форматов для процентов

Десятичные числа можно отображать в виде дробей, используя коды форматов вида «?/?».

Коды форматов для дробей

Экспоненциальное представление — это способ отображения значения в виде десятичного числа от 1 до 10, умноженного на 10 в некоторой степени. Этот формат часто используется для краткого отображения больших чисел.

Коды форматов для экспоненциального представления

В Excel доступны четыре дополнительных формата:

  • «Почтовый индекс» («00000»);
  • «Индекс + 4» («00000-0000»);
  • «Номер телефона» («[
  • «Табельный номер» («000-00-0000»).

Дополнительные форматы для функции ТЕКСТ

Дополнительные форматы зависят от региональных параметров. Если же дополнительные форматы недоступны для вашего региона или не подходят для ваших нужд, вы можете создать собственный формат, выбрав в диалоговом окне Формат ячеек пункт (все форматы).

Типичный сценарий

Функция ТЕКСТ редко используется сама по себе, а чаще применяется в сочетании с чем-то еще. Предположим, что вы хотите объединить текст и числовое значение, например, чтобы получить строку «Отчет напечатан 14.03.12» или «Еженедельный доход: 66 348,72 ₽». Такие строки можно ввести вручную, но суть в том, что Excel может сделать это за вас. К сожалению, при объединении текста и форматированных чисел, например дат, значений времени, денежных сумм и т. п., Excel убирает форматирование, так как неизвестно, в каком виде нужно их отобразить. Здесь пригодится функция ТЕКСТ, ведь с ее помощью можно принудительно отформатировать числа, задав нужный код формата, например «ДД.ММ.ГГГГ» для дат.

В примере ниже показано, что происходит, если попытаться объединить текст и число, не применяя функцию ТЕКСТ. Мы используем амперсанд (&) для сцепления текстовой строки, пробела (» «) и значения: =A2&» «&B2.

Пример объединения текста без функции ТЕКСТ

Вы видите, что значение даты, взятое из ячейки B2, не отформатировано. В следующем примере показано, как применить нужное форматирование с помощью функции ТЕКСТ.

Пример объединения текста с помощью функции ТЕКСТ

Вот обновленная формула:

  • ячейка C2:=A2&» «&ТЕКСТ(B2;»дд.мм.гггг») — формат даты.

Вопросы и ответы

Как преобразовать числа в текст, например 123 в «сто двадцать три»?

К сожалению, вы не можете сделать это с помощью функции TEXT; необходимо использовать код Visual Basic для приложений (VBA). Следующая ссылка содержит метод: Как преобразовать числовое значение в слова на английском языке в Excel.

Можно ли изменить регистр текста?

Да, вы можете использовать функции ПРОПИСН, СТРОЧН и ПРОПНАЧ. Например, формула =ПРОПИСН(«привет») возвращает результат «ПРИВЕТ».

Можно ли с помощью функции ТЕКСТ добавить новую строку (разрыв строки) в ячейке, как при нажатии клавиш ALT+ВВОД?

Да, но для этого необходимо выполнить несколько действий. Сначала выберите ячейку или ячейки, в которых это произойдет, и нажмите клавиши CTRL+1, чтобы открыть диалоговое окно Формат > ячеек, а затем элемент управления Выравнивание > текст > проверка параметр Обтекать текстом. После этого добавьте в функцию ТЕКСТ код ASCII СИМВОЛ(10) там, где нужен разрыв строки. Вам может потребоваться настроить ширину столбца, чтобы добиться нужного выравнивания.

Пример использования функций ТЕКСТ и СИМВОЛ(10) для вставки разрыва строки: =

В этом примере использована формула =»Сегодня: «&СИМВОЛ(10)&ТЕКСТ(СЕГОДНЯ();»ДД.ММ.ГГ»).

Почему Excel преобразует введенные числа во что-то вроде «1,22E+07»?

Это называется научной нотацией, и Excel автоматически преобразует числа, превышающие 12 цифр, если ячейки форматируются как общие, и 15 цифр, если ячейки отформатированы как число. Если вам нужно ввести длинные числовые строки, но не нужно их преобразовывать, отформатируйте ячейки, о которой идет речь, как Текст , прежде чем вводить или вставлять значения в Excel.

Даты на разных языках

Минда Триси (Mynda Treacy), Excel MVP

Минда советует.

Если вы предоставляете общий доступ к файлам и отчетам Excel пользователям из разных стран, скорее всего, потребуется, чтобы они были на разных языках. Минда Триси (Mynda Treacy), Excel MVP, предлагает отличное решение этой задачи в своей статье Отображение дат Excel на разных языках (на английском). В ней также есть пример книги, который вы можете скачать.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *