Как присвоить имя диапазону в excel
Перейти к содержимому

Как присвоить имя диапазону в excel

  • автор:

Определение и использование имен в формулах

Использование имен позволяет значительно упростить понимание и изменение формул. Вы можете задать имя для диапазона ячеек, функции, константы или таблицы. Начав использовать имена в книге, вы сможете с легкостью обновлять, проверять имена и управлять ими.

Браузер не поддерживает видео. Установите Microsoft Silverlight, Adobe Flash Player или Internet Explorer 9.

Присвоение имени ячейке

Поле

  1. Выделите ячейку.
  2. Введите имя в поле Имя.

Чтобы ссылаться на это значение в другой таблице, введите знак равенства (=) и Имя, а затем нажмите клавишу ВВОД.

Присвоение имен из выделенного диапазона
  1. Выберите диапазон, которому вы хотите присвоить имя, включая заголовки строк и столбцов.
  2. На вкладке Формулы нажмите кнопку Создать из выделенного
  3. В диалоговом окне Создание имен из выделенного диапазона укажите местоположение, содержащее метки, установив флажок в строке выше,в столбце слева, в строке ниже или в столбце справа.
  4. Нажмите кнопку ОК. Excel присвоит ячейкам имена на основе заголовков из указанного диапазона.
Использование имен в формулах
  1. Выделите ячейку и введите формулу.
  2. Поместите курсор туда, где вы хотите использовать в формуле имя.
  3. Введите первую букву имени и выберите его из появившегося списка. Или выберите Формулы >Использовать в формуле и выберите имя, которое хотите использовать.
  4. Нажмите клавишу Ввод.
Управление именами в книге с помощью Диспетчера имен
  1. На ленте выберите Формулы >Диспетчер имен. Здесь можно создавать, редактировать, удалять и искать все имена, используемые в книге.

Присвоение имени ячейке

Поле

  1. Выделите ячейку.
  2. Введите имя в поле Имя.

Присвоение имен из выделенного диапазона

  1. Выберите диапазон, которому вы хотите присвоить имя, включая заголовки строк и столбцов.
  2. На вкладке Формулы нажмите кнопку Создать из выделенного
  3. В диалоговом окне Создание имен из выделенного диапазона укажите место, содержащее заголовки, установив флажок в строке вышев столбце слева, в строке ниже или в столбце справа.
  4. Выберите OK. Excel присвоит ячейкам имена на основе заголовков из указанного диапазона.

Использование имен в формулах

  1. Выделите ячейку и введите формулу.
  2. Поместите курсор туда, где вы хотите использовать в формуле имя.
  3. Введите первую букву имени и выберите его из появившегося списка. Или выберите Формулы >Использовать в формуле и выберите имя, которое хотите использовать.
  4. Нажмите клавишу Ввод.

Управление именами в книге с помощью Диспетчера имен

  1. На ленте выберите команды Формулы > Определенные имена >Диспетчер имен. Здесь можно создавать, редактировать, удалять и искать все имена, используемые в книге.

В Excel в Интернете вы можете использовать именованные диапазоны, которые вы определили в Excel для Windows или Mac. Выберите имя в поле «Имя» для перехода к расположению диапазона или использования именованного диапазона в формуле.

На данный момент создание нового именованного диапазона в Excel в Интернете недоступно.

Дополнительные сведения

Вы всегда можете задать вопрос эксперту в Excel Tech Community или получить поддержку в сообществах.

Присвоение имени ячейке или диапазону данных в Excel с помощью средства чтения с экрана

Эта статья предназначена для людей с нарушениями зрения или когнитивных функций, использующих программы чтения с экрана, такие как WindowsЭкранный диктор, JAWS или NVDA, с продуктами Microsoft 365. Эта статья входит в набор содержимого поддержки средства чтения с экрана Microsoft 365, где содержатся дополнительные сведения о специальных возможностях в наших приложениях. Чтобы получить справку общего характера, посетите службу поддержки Майкрософт.

Используйте Excel с клавиатурой и средством чтения с экрана, чтобы именовать ячейки и диапазоны данных на листе. Мы проверили эту функцию с использованием экранного диктора, JAWS и NVDA, но она может работать и с другими средствами чтения с экрана, если они соответствуют общепринятым стандартам и методам для специальных возможностей. Вы можете использовать имя в формуле и сделать формулу гораздо проще для понимания и обслуживания.

  • Новые возможности Microsoft 365 становятся доступны подписчикам Microsoft 365 по мере выхода, поэтому в вашем приложении эти возможности пока могут отсутствовать. Чтобы узнать о том, как можно быстрее получать новые возможности, станьте участником программы предварительной оценки Office.
  • Дополнительные сведения о средствах чтения с экрана см. в статье О работе средств чтения с экрана в Microsoft 365.

Присвоение имени ячейке или диапазону данных

  1. Выделите ячейку или диапазон ячеек, чтобы присвоить имя.
  2. Нажмите клавиши ALT+M, M, D. Экранный диктор и NVDA прозвучит сообщение «Новое окно имени». При использовании JAWS вы услышите фразу «Имя, двоеточие, изменить». Фокус будет сделан на поле Имя: .
  3. Введите имя ячейки или диапазона данных.

Примечание: Имя должно начинаться с буквы или подчеркивания и не может содержать пробелы.

См. также

Используйте Excel для Mac с помощью клавиатуры и voiceOver, встроенного в macOS средства чтения с экрана, чтобы именовать ячейки и диапазоны данных на листе. Затем вы можете использовать это имя в формуле и сделать формулу гораздо проще для понимания и обслуживания.

  • Новые возможности Microsoft 365 становятся доступны подписчикам Microsoft 365 по мере выхода, поэтому в вашем приложении эти возможности пока могут отсутствовать. Чтобы узнать о том, как можно быстрее получать новые возможности, станьте участником программы предварительной оценки Office.
  • В этой статье предполагается, что вы используете VoiceOver — средство чтения с экрана, встроенное в macOS. Дополнительные сведения об использовании VoiceOver см. в кратком руководстве по началу работы с VoiceOver.

Присвоение имени ячейке или диапазону данных

  1. В электронной таблице Excel выберите ячейку или диапазон ячеек, которым требуется присвоить имя.
  2. Нажимайте клавишу F6, пока не услышите имя выбранной вкладки, например «Главная, выбрано, вкладка», а затем нажимайте клавиши CONTROL+OPTION+СТРЕЛКА ВЛЕВО или СТРЕЛКА ВПРАВО, пока не услышите фразу «Формулы, вкладка». Нажмите клавиши CONTROL+OPTION+ПРОБЕЛ, чтобы открыть вкладку Формулы .
  3. Нажимайте клавишу TAB, пока не услышите фразу «Определить имя, кнопка меню», а затем нажмите клавиши CONTROL+OPTION+ПРОБЕЛ. Откроется диалоговое окно Определение имени , и вы услышите сообщение «Имена в книге, таблице».
  4. Нажимайте клавишу TAB, пока не услышите фразу «Введите имя диапазона данных, измените текст», а затем введите имя ячейки или диапазона данных.

Примечание: Имя должно начинаться с буквы или подчеркивания и не может содержать пробелы.

Примечание: Чтобы прочитать имя ячейки или диапазона данных, после выбора ячейки или диапазона данных нажимайте клавишу F6, пока не услышите имя ячейки или диапазона данных, а затем фразу «Выбрано содержимое, изменить текст».

См. также

Техническая поддержка пользователей с ограниченными возможностями

Корпорация Майкрософт стремится к тому, чтобы все наши клиенты получали наилучшие продукты и обслуживание. Если у вас ограниченные возможности или вас интересуют вопросы, связанные со специальными возможностями, обратитесь в службу Microsoft Disability Answer Desk для получения технической поддержки. Специалисты Microsoft Disability Answer Desk знакомы со многими популярными специальными возможностями и могут оказывать поддержку на английском, испанском, французском языках, а также на американском жестовом языке. Перейдите на сайт Microsoft Disability Answer Desk, чтобы узнать контактные сведения для вашего региона.

Если вы представитель государственного учреждения или коммерческой организации, обратитесь в службу Disability Answer Desk для предприятий.

Имена в формулах

Имя — это понятное сокращение, которое упрощает понимание назначения ссылка на ячейку, константа, формула или таблица, каждое из которых может быть трудно понять на первый взгляд. Ниже приведены общие примеры имен и способы их улучшения.

Тип примера

Пример без имени

Пример с именем

Дополнительно об использовании имен

Существует несколько типов имен, которые можно создавать и использовать.

Определенное имя Имя, представляющее ячейку, диапазон ячеек, формулу или значение константы. Вы можете создать собственное определенное имя или Excel может создать определенное имя для вас, например при настройке области печати.

Имя таблицы Имя таблицы Excel, которая представляет собой коллекцию данных о конкретном субъекте, хранящихся в записях (строках) и полях (столбцах). Excel создает имя таблицы Excel по умолчанию Table1, Table2 и т. д. каждый раз, когда вы вставляете таблицу Excel. Вы можете изменить имя таблицы, чтобы сделать ее более понятной. Дополнительные сведения о таблицах Excel см. в разделе Использование структурированных ссылок с таблицами Excel.

Область действия имени

Все имена имеют область действия: это может быть определенный лист (локальный уровень листа) или вся книга (глобальный уровень книги). Область имени — это расположение, в котором имя распознается без квалификации. Например:

  • Если вы определили имя, например Budget_FY08, и его область является Sheet1, это имя, если оно не указано, распознается только на листе Лист1, но не на других листах. Чтобы использовать локальное имя листа на другом листе, его можно указать, предваряя его именем листа. Например: Лист1!Бюджет_ФГ08
  • Если вы определили имя, например Sales_Dept_Goals, и его область является книга, это имя распознается для всех листов в этой книге, но не для других книг.

Имя должно быть уникальным в пределах своей области действия. Excel не позволяет определить имя, которое уже существует в его область. При этом можно использовать одинаковые имена в разных областях действия. Например, можно определить имя «ВаловойДоход» в областях действия «Лист1», «Лист2» и «Лист3» в одной и той же книге. Несмотря на одинаковость, каждое имя уникально в пределах своей области действия. Это можно сделать, чтобы убедиться, что формула, использующая имя GrossProfit, всегда ссылается на одни и те же ячейки на локальном уровне листа.

Можно даже определить это же имя «ВаловойДоход» на глобальном уровне книги, но область действия опять будет уникальной. Однако в этом случае может возникнуть конфликт имен. Чтобы устранить этот конфликт, По умолчанию Excel использует имя, определенное для листа, так как локальный уровень листа имеет приоритет над уровнем глобальной книги. Если вы хотите переопределить приоритет и использовать имя книги, вы можете дизамбигировать имя, указав префикс имени книги. Например:

Вы можете переопределить локальный уровень листа для всех листов в книге. Одним из исключений является первый лист, на котором всегда используется локальное имя, если существует конфликт имен, который невозможно переопределить.

Определение и ввод имен

Имя определяется с помощью:

  • Поле «Определенные имена» в строке формул Этот способ лучше всего использовать для создания имени на уровне книги для выделенного диапазона.
  • Определение имени из выделенного фрагмента Можно удобно создавать имена из существующих имен строк и столбцов с помощью выделения ячеек на листе.
  • Диалоговое окно «Создание имени». Это лучше всего использовать, если нужна большая гибкость при создании имен, например, задание области определения на локальном уровне листа или создание примечания к имени.

Примечание. По умолчанию имена используют абсолютные ссылки на ячейки.

Имя можно ввести указанными ниже способами.

  • Ввода Введите имя, например, в качестве аргумента формулы.
  • Автозавершение формул. Используйте раскрывающийся список автозавершения формул, в котором автоматически выводятся допустимые имена.
  • Выбором из команды «Использовать в формуле». Выберите определенное имя на вкладке Формулы в группе Определенные имена из списка Использовать в формуле.

Имена аудита

Вы также можете создать список определенных имен в книге. Выберите на листе место с двумя пустыми столбцами (список будет содержать два столбца: один для имен и один для описаний имен). Выберите ячейку, которая будет верхним левым углом списка. На вкладке Формулы в группе Определенные имена нажмите кнопку Использовать в формуле, нажмите кнопку Вставить , а затем в диалоговом окне Вставить имена нажмите кнопку Вставить список.

Сведения о синтаксических правилах для имен

Ниже приведен список правил синтаксиса для создания и изменения имен.

  • Допустимые символы. Первым символом имени должна быть буква, знак подчеркивания (_) или обратная косая черта (\). Остальные символы имени могут быть буквами, цифрами, точками и знаками подчеркивания. Совет. Вы не можете использовать прописные и строчные буквы «C», «c», «R» или «r» в качестве определенного имени, так как они используются в качестве сокращения для выбора строки или столбца для выбранной ячейки при вводе их в текстовое поле Имя или Перейти к.
  • Имена в виде ссылок на ячейки запрещены. Имена не могут быть такими же, как ссылки на ячейки, например, Z$100 или R1C1.
  • Недопустимые пробелы Использовать в имени пробелы нельзя. Используйте символ подчеркивания (_) и точку (.) как разделители слов, например, Sales_Tax или First.Quarter.
  • Длина имени. Имя может содержать до 255 символов.
  • Учет регистра. Имя может состоять из строчных и прописных букв. Excel не различает строчные и прописные буквы в именах. Например, если вы создадите имя Sales, а затем другое имя SALES в той же книге, Excel предложит выбрать уникальное имя.

Создание на листе имени для ячейки или диапазона ячеек

  1. Выделите ячейку, диапазон ячеек или несмежные ячейки, которым вы хотите присвоить имя.
  2. Щелкните поле Имя у левого края строка формул.

Примечание: При изменении содержимого ячейки ей нельзя присвоить имя.

Создание имени путем выделения ячеек на листе

Можно преобразовать в имена существующие заголовки строк и столбцов.

  1. Выберите диапазон, которому вы хотите присвоить имя, включая заголовки строк и столбцов.
  2. На вкладке Формулы в группе Определенные имена нажмите кнопку Создать из выделенного фрагмента.

Создание имени с помощью диалогового окна «Создание имени»

  1. На вкладке Формулы в группе Определенные имена выберите пункт Присвоить имя.

    Чтобы указать ссылку на ячейки, введите ссылку на ячейки. Совет. Текущий выбор вводится по умолчанию. Чтобы ввести другие ссылки на ячейки в качестве аргумента, щелкните Свернуть диалоговое окно

(что временно сжимает диалоговое окно), выделите ячейки на листе и нажмите кнопку Развернуть диалоговое окно

Совет: Чтобы расширить или удлинить диалоговое окно Создание имени, щелкните и перетащите маркер захвата, расположенный внизу.

Управление именами с помощью диалогового окна диспетчера имен

Используйте диалоговое окно Диспетчер имен для работы со всеми определенными именами и именами таблиц в книге. Например, может потребоваться найти имена с ошибками, подтвердить значение и ссылку на имя, просмотреть или изменить описательные комментарии или определить область. Вы также можете сортировать и фильтровать список имен, а также легко добавлять, изменять или удалять имена из одного расположения.

Чтобы открыть диалоговое окно Диспетчер имен, на вкладке Формулы в группе Определенные имена нажмите кнопку Диспетчер имен.

Просмотр имен

В диалоговом окне Диспетчер имен отображаются следующие сведения о каждом имени в списке.

Этот столбец:

Одно из следующих значений:

Текущее значение имени, такое как результаты формулы, строковая константа, диапазон ячеек, ошибка, массив значений или знаки-заполнители, если формулу не удается вычислить. Вот типичные примеры.

Текущая ссылка для имени. Вот типичные примеры.

  • имя листа, если область действия — локальный уровень листа;
  • «Книга», если область является глобальным уровнем листа.

Дополнительные сведения об имени длиной до 255-ти знаков. Вот типичные примеры.

  • Срок действия этого значения истекает 2 мая 2007 г.
  • Не удалять! Критическое имя!
  • Основано на числах экзамена на сертификацию ISO.
  • Диалоговое окно Диспетчер имен нельзя использовать при изменении содержимого ячейки.
  • В диалоговом окне Диспетчер имен не отображаются имена, определенные в Visual Basic для приложений (VBA), или скрытые имена (свойство Visible имени имеет значение False).

Изменение размера столбцов

  • Чтобы автоматически размер столбца соответствовал самому длинному значению в этом столбце, дважды щелкните правую часть заголовка столбца.

Именованный диапазон в EXCEL

Обычно ссылки на диапазоны ячеек вводятся непосредственно в формулы, например =СУММ(А1:А10) . Другим подходом является использование в качестве ссылки имени диапазона. В статье рассмотрим какие преимущества дает использование имени.

Назовем Именованным диапазоном в MS EXCEL, диапазон ячеек, которому присвоено Имя (советуем перед прочтением этой статьи ознакомиться с правилами создания Имен ).

Преимуществом именованного диапазона является его информативность. Сравним две записи одной формулы для суммирования, например, объемов продаж: =СУММ($B$2:$B$10) и =СУММ(Продажи) . Хотя формулы вернут один и тот же результат (если, конечно, диапазону B2:B10 присвоено имя Продажи ), но иногда проще работать не напрямую с диапазонами, а с их именами.

Совет : Узнать на какой диапазон ячеек ссылается Имя можно через Диспетчер имен расположенный в меню Формулы/ Определенные имена/ Диспетчер имен .

Ниже рассмотрим как присваивать имя диапазонам. Оказывается, что диапазону ячеек можно присвоить имя по разному: используя абсолютную или смешанную адресацию .

Задача1 (Именованный диапазон с абсолютной адресацией)

Пусть необходимо найти объем продаж товаров (см. файл примера лист 1сезон ):

Присвоим Имя Продажи диапазону B2:B10 . При создании имени будем использовать абсолютную адресацию .

  • выделите, диапазон B2:B10 на листе 1сезон ;
  • на вкладке Формулы в группе Определенные имена выберите команду Присвоить имя ;
  • в поле Имя введите: Продажи ;
  • в поле Область выберите лист 1сезон (имя будет работать только на этом листе) или оставьте значение Книга , чтобы имя было доступно на любом листе книги;
  • убедитесь, что в поле Диапазон введена формула =’1сезон’!$B$2:$B$10
  • нажмите ОК.

Теперь в любой ячейке листа 1сезон можно написать формулу в простом и наглядном виде: =СУММ(Продажи) . Будет выведена сумма значений из диапазона B2:B10 .

Также можно, например, подсчитать среднее значение продаж, записав =СРЗНАЧ(Продажи) .

Обратите внимание, что EXCEL при создании имени использовал абсолютную адресацию $B$1:$B$10 . Абсолютная ссылка жестко фиксирует диапазон суммирования: в какой ячейке на листе Вы бы не написали формулу =СУММ(Продажи) – суммирование будет производиться по одному и тому же диапазону B1:B10 .

Иногда выгодно использовать не абсолютную, а относительную ссылку, об этом ниже.

Задача2 (Именованный диапазон с относительной адресацией)

Теперь найдем сумму продаж товаров в четырех сезонах. Данные о продажах находятся на листе 4сезона (см. файл примера ) в диапазонах: B2:B10 , C 2: C 10 , D 2: D 10 , E2:E10 . Формулы поместим соответственно в ячейках B11 , C 11 , D 11 , E 11 .

По аналогии с абсолютной адресацией из предыдущей задачи, можно, конечно, создать 4 именованных диапазона с абсолютной адресацией, но есть решение лучше. С использованием относительной адресации можно ограничиться созданием только одного Именованного диапазона Сезонные_продажи .

  • выделите ячейку B11 , в которой будет находится формула суммирования (при использовании относительной адресации важно четко фиксировать нахождение активной ячейки в момент создания имени );
  • на вкладке Формулы в группе Определенные имена выберите команду Присвоить имя ;
  • в поле Имя введите: Сезонные_Продажи ;
  • в поле Область выберите лист 4сезона (имя будет работать только на этом листе);
  • убедитесь, что в поле Диапазон введена формула =’4сезона’!B$2:B$10
  • нажмите ОК.

Мы использовали смешанную адресацию B$2:B$10 (без знака $ перед названием столбца). Такая адресация позволяет суммировать значения находящиеся в строках 2 , 3 ,… 10 , в том столбце, в котором размещена формула суммирования. Формулу суммирования можно разместить в любой строке ниже десятой (иначе возникнет циклическая ссылка).

Теперь введем формулу =СУММ(Сезонные_Продажи) в ячейку B11. Затем, с помощью Маркера заполнения , скопируем ее в ячейки С11 , D 11 , E 11 , и получим суммы продаж в каждом из 4-х сезонов. Формула в ячейках B 11, С11 , D 11 и E 11 одна и та же!

СОВЕТ: Если выделить ячейку, содержащую формулу с именем диапазона, и нажать клавишу F2 , то соответствующие ячейки будут обведены синей рамкой (визуальное отображение Именованного диапазона ).

Использование именованных диапазонов в сложных формулах

Предположим, что имеется сложная (длинная) формула, в которой несколько раз используется ссылка на один и тот же диапазон:

Если нам потребуется изменить ссылку на диапазон данных, то это придется сделать 3 раза. Например, ссылку E2:E8 поменять на J14:J20 .

Но, если перед составлением сложной формулы мы присвоим диапазону E2:E8 какое-нибудь имя (например, Цены ), то ссылку на диапазон придется менять только 1 раз и даже не в формуле, а в Диспетчере имен !

Более того, при создании формул EXCEL будет сам подсказывать имя диапазона! Для этого достаточно ввести первую букву его имени.

Excel добавит к именам формул, начинающихся на эту букву, еще и имя диапазона!

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *